Highspot Marketplace Currently Unavailable
Incident Report for Highspot
Resolved
The Highspot Marketplace is back up & available.
Posted Nov 06, 2024 - 12:41 PST
Investigating
We are currently investigating the Highspot Marketplace being down. Our Engineering Team is investigating this with the highest priority at the moment. We will provide another update by 3PM PT.
Posted Nov 06, 2024 - 12:04 PST