We are continuing to work on a fix for this issue.
Posted Mar 30, 2021 - 16:55 PDT
Update
We continue to work on an issue related to Email Pitching in our AMERICAS1 Region. Our Engineers are actively working on this issue with high priority. We will provide an update at 5:00pm Pacific Time.
Posted Mar 30, 2021 - 16:33 PDT
Update
We continue to work on an issue related to Email Pitching in our AMERICAS1 Region. Our Engineers are actively working on this issue with high priority. We will provide an update at 4:30pm Pacific Time.
Posted Mar 30, 2021 - 16:00 PDT
Update
We continue to work on an issue related to Email Pitching in our AMERICAS1 Region. Our Engineers are actively working on this issue with high priority. We will provide an update at 4:00pm Pacific Time.
Posted Mar 30, 2021 - 15:32 PDT
Identified
We have identified an issue related to Email Pitching in our AMERICAS1 Data Center. Our Engineers are actively working on this issue with high priority. We will provide an update at 3:30pm Pacific Time.
Posted Mar 30, 2021 - 15:00 PDT
Update
We are continuing to investigate reports regarding an issue related to Email Pitching in our AMERICAS1 Data Center. Some customers may observe email pitch activity events noting that an email could not be delivered because the email account does not appear to be valid. We will provide an update at 3:00pm Pacific Time.
Posted Mar 30, 2021 - 14:31 PDT
Investigating
We are investigating reports regarding an issue related to Pitching in our AMERICAS1 Data Center.
We are actively investigating this issue and will provide further details regarding symptoms and scope at 2:30pm Pacific Time.