The ability to re-share existing Pitches and Digital Rooms using the Share button while viewing externally is fully operational once again. This is now resolved.
Posted Dec 15, 2025 - 09:09 PST
Update
The ability to re-share existing Pitches and Digital Rooms using the Share button while viewing externally remains temporarily unavailable due to maintenance. The creation, sending, and tracking of all other Pitch and Digital Room functions are fully operational and unaffected. We will provide another update by Monday, 12/15 at 5PM PT.
Posted Dec 11, 2025 - 16:57 PST
Monitoring
The ability to re-share existing Pitches and Digital Rooms using the Share button while viewing externally is temporarily unavailable due to maintenance. We will provide another update by 5PM PT.
Posted Dec 11, 2025 - 11:06 PST
This incident affected: AMERICAS1 (Pitches), AMERICAS2 (Pitches), EMEA1 (Pitches), EMEA2 (Pitches), and APAC1 (Pitches).