Performance issues in AMERICAS2 Data Center

Incident Report for Highspot

Resolved

The Engineering Team has resolved the performance issues in the AMERICAS2 Data Center. Everything is fully operational again.
Posted Mar 03, 2026 - 09:44 PST

Investigating

We are currently investigating reports of performance and latency issues in the AMERICAS2 Data Center. We will provide another update by 10AM PT.
Posted Mar 03, 2026 - 08:56 PST
This incident affected: AMERICAS2 (Administration & Authentication, Analytics, Content, CRM Integration, Learning, Pitches, Search, Support Center, Engagement).