Platform Incident

Incident Report for Highspot

Resolved

The issue that impacted multiple features on all Data Centers has now been resolved.

All customers with impacted customer have been notified.
Posted Nov 10, 2025 - 05:03 PST

Investigating

We are investigating reports regarding an issue the is impacting the Highspot Platform. This is impacting all our Scale Units and multiple features on the platform.

We are actively investigating this issue and will provide further details regarding symptoms and scope at 05:00 Pacific Time.
Posted Nov 10, 2025 - 04:31 PST
This incident affected: AMERICAS1 (Administration & Authentication, Analytics, Pitches, Engagement), EMEA1 (Administration & Authentication, Analytics, Pitches, Engagement), AMERICAS2 (Administration & Authentication, Analytics, Pitches, Engagement), EMEA2 (Administration & Authentication, Analytics, Pitches, Engagement), and APAC1 (Administration & Authentication, Analytics, Pitches, Engagement).